Setting Queue Tree RB750 Mikrotik

.

Berikut ini tutorial cara membagi bandwith pada RB750 dengan metode Queue Tree dan telah saya uji pada PTP X Kertosari. Biar lebih gampang saya buat kasus membagi speedy paket 384 untuk 3 client.
Bandwidth Total= 400k (hasil speedtest)
Jumlah Client = 3
IP Modem = 192.168.1.1 (default)
IP Client = 192.168.88.2-192.168.88.4 (default)
IP Mikrotik = 192.168.88.1 (gateway)

1. Buat Mangle :
/ip firewall mangle
(menangkap semua traffic/koneksi client satu persatu. ulangi rule ini sesuai dengan banyaknya client anda)

Client1
add chain=forward action=mark-connection new-connection-mark=con1 passthrough=yes dst-address=192.168.1.2 add chain=forward action=mark-packet new-packet-mark=p1 passthrough=no connection-mark=con1

Client2
add chain=forward action=mark-connection new-connection-mark=con2 passthrough=yes dst-address=192.168.1.3 add chain=forward action=mark-packet new-packet-mark=p2 passthrough=no connection-mark=con2

Client3
add chain=forward action=mark-connection new-connection-mark=con3 passthrough=yes dst-address=192.168.1.4 add chain=forward action=mark-packet new-packet-mark=p3 passthrough=no connection-mark=con3

2. Buat Queue Tree
Skenario rule queue tree saya, Priority 1 (Pimpinan), Priority 2 (Manajer), Priority 3 (staff). Kita ingin mengalokasikan bandwidth sebesar 400kbps untuk 3 client, di mana masing-masing client bisa mendapatkan maksimal 200kbps. Di antara ketiga client tersebut, memiliki prioritas yang berbeda, yaitu: 1,2, dan 3.

/queue tree (melihat total bandwidth yang digunakan oleh semua client)
add name="parent" parent=global-out queue=default priority=8 max-limit=400k
(membatasi bandwidth per client)
add name="q1" parent=all packet-mark=p1 limit-at=75k queue=default priority=1 max-limit=200k
add name="q2" parent=all packet-mark=p2 limit-at=75k queue=default priority=2 max-limit=200k
add name="q3" parent=all packet-mark=p3 limit-at=75k queue=default priority=3 max-limit=200k

Hasilnya: Mantap... sesuai skenario dan priority client


Penting:
Jumlah akumulatif dari limit-at tidaklah boleh melebihi max-limit parent. Jika hal itu terjadi, jumlah limit-at ketiga client adalah 600kbps, sedangkan nilai max-limit parent hanyalah 400kbps, maka max-limit parent akan bocor. Asumsikan bahwa kapasitas keseluruhan memang bisa mencapai nilai total limit-at. Namun, apabila bandwidth yang tersedia tidak mencapai total limit-at, maka client akan kembali berebutan dan sistem prioritas menjadi tidak bekerja.


Berikut queue tree tanpa parent. Meskipun sekarang q1 sudah memiliki prioritas tertinggi, namun ketiga client masih berebutan bandwidth dan tidak terkontrol. Priority tidak terkontrol.



Sekarang, saya akan memasang parameter max-limit pada parent queue tapi client tanpa limit-at, hasilnya seperti dibawah ini, client 3 tidak mendapat jatah bandwith yang cukup.



Panduan praktis cara perhitungan limit-at dan max-limit

Di asumsikan bandwidth yang tersedia sebesar 1000kbps. Dan jumlah seluruh client adalah 70.  Yang perlu diketahui adalah
  1. Berapa jumlah maksimal client yang menggunakan internet pada saat yang bersamaan. Jumlah ini belum tentu sama dengan jumlah komputer yang ada, apabila semua client tidak pernah terkoneksi secara bersamaan. Sebagai contoh, untuk kasus ini kita asumsikan adalah 50.
  2. Berapa jumlah minimal client yang menggunakan internet pada saat yang bersamaan.
Sebagai contoh, untuk kasus ini kita asumsikan adalah 10
Maka, untuk setiap client (1 client dibuatkan 1 rule queue), limit-at nya adalah 1000 / 50 = 20kbps, dan max-limit nya adalah 1000 / 10 = 100 kbps.

Jangan lupa untuk menambahkan parent dengan max-limit sebesar 1000kbps (tidak perlu limit-at), dan memasukkan semua queue client di bawah parent queue. Jika untuk terminal tertentu membutuhkan priority lebih besar, maka kita bisa menggunakan priority yang berbeda-beda, tergantung dengan urutan prioritasnya.

6 comments:

Anonymous said...

http://us.i1.yimg.com/us.yimg.com/i/mesg/emoticons7/100.gif

Anonymous said...

alangkah bagusnya kalau setiap posting blog disertakan subernya bro :)
inikan punyanya bung Valen riyadi

Anonymous said...

:)) =))

Anonymous said...

:))

yulianti syahwaludi said...

:)) =)) :D =))

yulianti syahwaludi said...
This comment has been removed by the author.
:)) ;)) ;;) :D ;) :p :(( :) :( :X =(( :-o :-/ :-* :| 8-} :)] ~x( :-t b-( :-L x( =))

Post a Comment

 

Followers

Komentar Baru

Support by | Allianz